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Preface 

Purpose 
The purpose of this document is to describe how to configure the Elcbas/SEA 
system using the Elcbas Configuration Tool (ElcCfg) 

Intended Audience 
This is a technical document. Some knowledge of Elcom and Elcom configuration 
rules is assumed. 

Structure of the Document 
This document starts with an overview and two how-to chapters, followed by 
reference information for all menus and dialogs. 

Associated Documents 
1. TR A5835 – Elcbas/SEA for Windows Administrators Guide 

2. TR A5833 – Elcbas/SEA Programmers Guide 

3. TR A3825 – Elcom User Element Conventions 

4. TR A4124 Elcom-90 Application Service Element, User’s Manual. 

Consult [3] for a more extensive list of Elcom documentation. 

Acronyms 
SEA Simplified Elcom API 

API  Application Programming Interface 

SEAIN The initiator in the Elcbas/SEA system 

SEARS The responder in the Elcbas/SEA system 

Trademarks 
None. 
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1. Introduction 

1.1 An introduction to the Elcom Protocol 
The Elcom Protocol allows transfer of point data of various formats as current 
data or time series, as well as supervisory control. 

Please refer to the standard Elcom-90 documentation for further information. 

1.2 A Sample Scenario 
A system with one partner and one client could look like this: 

 

Figure 1 Sample Elcbas Scenario 
In this figure: 

• sears, seain and e90 are processes that comprise the elcbas run-time 
system. 

• myClient is a client application for both initiator and responder, which 
forms the interface with whatever system actually uses/supplies the Elcom 
data for this scenario. 

• myPartner is a remote Elcom partner (may run Elcbas or other Elcom 
implementations). 

• sears-cfg.ecf and seain-cfg.ecf are the configuration files for the responder 
and initiator processes (sears and seain). 
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1.3 Key Terms, Basic Rules 

1.3.1 Clients 
The term client is used to define programs interacting with the Elcbas system 
through the Simplified Elcom API (SEAPI) to deliver data, receive data or both. 
A functional Elcbas system has at least one client, but may have several. The 
relationships between clients and data are configurable. 

A client may serve both initiator and responder requests, but it must then be 
configured separately for each server. 

Please refer to the Programmers Guide for details on how to develop clients. 

1.3.2 Partners 
The term partner is used to define a remote Elcom system that an Elcbas 
installation is communicating with. If both the initiator and responder are 
communicating with a partner, it must be configured separately for each. 

1.3.3 Groups, Objects and Data Types 
The term group is used to define a set of objects that has the same type, and which 
are transferred in the same manner. The Elcbas Configuration tool is used to 
define groups for the initiator, and can be used to inspect groups defined by 
remote partners for the responder. 

The points in a group are called objects. Objects are identified by a name agreed 
upon between two partners. In addition, the Elcbas system may use a different 
name for an object when communicating with clients. 

Objects within Elcbas may be of the following types: 

• 32-bit (single precision) floating point 

• 16-bit integer (discrete) values 

• 2-bit status values (on, off, between) 

The Elcom data types for command and setpoints are defined by setting the 
transfer mode of a group to command. 

The Elcom data types Logical breaker and Text are not currently supported.  

1.3.4 Object Directories, Object Names and Object Sets 
The Elcbas/SEA system supports optional cross-referencing of object names, so 
that a different name may be used for any object towards a partner and a client 
(and towards different partners and clients, if relevant). 

The implementation of this uses the concept of an object directory, or namespace. 
Each client and partner must be associated with a single namespace, but several 
partners and/or clients may use the same namespace. If a partner and a client use 
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the same namespace, there will be no cross-referencing between them, ie. the 
same object names are used. 

Within a namespace, any name must uniquely identify one object, and one object 
may have one or two names. Two names are only allowed if one of the names is 
designated for command access, ie. it is possible to configure a command with a 
separate object for the resulting status value which share a name in another 
namespace. 

An Object Set is a list of objects that exist in one or two object directories (with or 
without cross-referencing). Object Sets are used to provide access control and 
cross-referencing in the responder. 

1.3.5 Transfer Methods 
The Elcbas/SEA system supports the following methods for transferring data: 

• Requested data transfer, including scheduled and manually requested data 
transfer in the initiator 

• Periodic data transfer 

• Unsolicited data transfer, including mixed data transfer 

• Command transfer, or supervisory control (commands and setpoints) 
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2. Overview of the Elcbas Configuration Tool 
The configuration for the initiator and responder in Elcbas/SEA is stored in 
separate XML files, with a file type of .ecf (Elcbas ConFiguration). The files are 
edited using the Elcbas Configuration Tool. You can start the tool by using the 
menus (a shortcut is installed under the group ‘Elcbas for Windows’), or by 
double-clicking a .ecf file. On a running system, the active configuration may also 
be retrieved directly from each of the servers. 

2.1 Description of Window and Panes 

 

Figure 2 Elcbas Configuration Tool Main Window 
The figure above shows the main window of the Elcbas Configuration Tool with 
some data. It consists of the following areas: 

• The Menu Bar 

• The Toolbar 

• The Configuration Tree (to the left) 

• The Log Window (at the bottom) 

• The Status Bar 
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• The View Area (to the right) 

The View menu allows control of the display of most of these, and the Window 
menu controls how data is displayed in the View Area.  

The Toolbar, Configuration Tree and Log Window may be undocked or docked 
differently by grabbing at the double line at one edge and dragging. 

Live configuration data may be read in from the initiator and/or responder on a 
running system, or configuration data may be read in from files, for offline 
editing. 

As several files or live configurations are opened, each gets a node in the 
Configuration Tree, and a window in the View Area. 

2.2 Navigation and Operation 
The tree allows top-level navigation within a configuration, and access to 
commands for data manipulation. Select a node in the tree, and access commands 
from the menu bar, toolbar or press the right mouse button for a context menu. 

Inapplicable commands are grayed out. 

The view area shows content information on the different levels. It is not currently 
possible to invoke commands from the view area; this must be done from the tree. 

Some common commands are: 

• New xxx – different new commands are available, depending on the 
selected item. These commands are available from the File->New menu, 
and from the right-click context menu. 

• Properties – invokes a properties editor of the relevant type. This 
command is available from the Edit menu and from the context menu. 

• Delete – removes the selected item from the configuration, usually after 
some validation and/or with a confirmation prompt. This command is 
available from the Edit menu and from the context menu. 
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3. How To: Configure an Initiator 
Start with an existing configuration, or create a new file with File->New 
Configuration, and then select Initiator from the resulting popup. 

 If creating a new file, a name like ElcCfg1 will be created, but to use in an Elcbas 
system, the filename must be seain-cfg.ecf. Note: do not attempt to overwrite the 
configuration of a running system. 

If the initiator is running, you may also retrieve the active configuration for 
modification by using the File->Get Active Configuration->Initiator command. 

If editing a live configuration, saving will send the updated configuration back to 
the initiator, and restart it to apply the changes. 

3.1 Server Configuration 
By selecting the node with the filename and invoking the Properties command 
(from the Edit menu or from the right-click context menu) you will get the 
property editor for the initiator server. 

As a minimum, select the Addresses tab, and configure one or more addresses for 
the initiator. These must match addresses configured for this system in the remote 
responder. 

You may also consider enabling the Elcom API log from the logging tab. 

Other parameters may be left at their default values. 

3.2 Client Configuration 
To have a useful initiator system, at least one client must be configured. Select the 
command New Client from the File menu or context menu. For each client 
supply: 

• A name, used in display and logs. 

• An api name, used in communication with the seapi. This string must 
match the name used in the SEAOpen call for the program in question. 
This defaults to the displayed name, truncated as necessary. 

• An object directory name. This also defaults to the client name. 

If you use the same client for all partners, specify the mapping between Elcom 
suffices and client(s) on the suffices tab in the server configuration, otherwise do 
this configuration at the partner’s suffices tab. 

3.3 Partner Configuration 
Create partners with the New Partner command, from the file menu or context 
menu, and then supply the following data: 
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In the main tab: 

• If you want to have different object names for the partner and the client(s), 
use a different object directory names, otherwise use the object directory 
name you specified for the client(s). 

• Ensure partner names are unique. 

• Select the proper Elcom version (the default is usually appropriate). 

• Add the partners certificate name (X.509 canonical name) if using TLS as 
the transport. Note: Use of this field requires the Elcom provider system to 
be properly configured for TLS, see [4]. 

In the addresses tab, add at least one address for the partner. 

In the suffices tab you must set the unsolicited and/or periodic suffices to use a 
permanent connection if you are going to use these transfer methods. 

3.4 Group Configuration 
Select a partner, and use the New Group command from the File menu or context 
menu. On the Attributes tab, you must supply a unique group number (for the 
partner), select the desired data type, and specify a transfer method. 

NOTE: If you are using cross-referenced object names, set these attributes, save 
by pressing OK, and reopen the editor by selecting the group in the tree and 
invoking the Properties command from the Edit menu or the context menu. This is 
necessary to get two columns in the Members tab. 

Select the members tab and enter object names in one or two columns. You may 
move about the list using the cursor keys or the tab key. Avoid blank lines, as this 
will terminate the group. 

Finally, you can use the Cycles tab to add schedules for requested data transfer 
(these will only be active if transfer mode is set to requested). 

3.5 Verifying Operation 
Save the file, either directly to seain-cfg.ecf in the runtime directory, or to any 
other name to work more later (again: do not save to a running system with this 
name). 

Start or restart the Elcbas Initiator system, and use the log files or other means to 
verify operation.  

As mentioned above, if the configuration was read from the initiator, save will 
write it back to it, and invoke a restart function. 

Once the initiator is running, the configuration may be re-read to inspect the 
configuration status of the groups (displayed on the first page of the group editor). 
This should be OK if the group has configured successfully. 
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If working on an active configuration, you may retrieve a set of values for a group 
by selecting the Fetch Data function from the Tools menu or the context menu. 
The data will be sent to the client for the group. 
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4. How To: Configure a Responder 
Start with an existing configuration, or create a new file with File->New 
Configuration, and then select Responder from the resulting popup. 

 If creating a new file, a name like ElcCfg1 will be created, but to use in an Elcbas 
system, the filename must be sears-cfg.ecf. Note: do not attempt to overwrite the 
configuration of a running system. 

If the initiator is running, you may also retrieve the active configuration for 
modification by using the File->Get Active Configuration->Responder command. 

If editing a live configuration, saving will send the updated configuration back to 
the responder, and restart it to apply the changes. 

4.1 Server Configuration 
By selecting the node with the filename and invoking the Properties command 
(from the Edit menu or from the right-click context menu) you will get the 
property editor for the responder server. 

The default values will provide an operational system, but you might want to 
consider the timer values on the timers tab, and also whether to enable the Elcom 
API log from the logging tab. 

4.2 Client Configuration 
At least one client must be configured for the responder to be useful. 

Select the command New Client from the File menu or context menu. For each 
client supply: 

• A name, used in display and logs. 

• An api name, used in communication with the seapi. This string must 
match the name used in the SEAOpen call for the program in question. 

• An object directory name. 

If a client is used by all (or more than one) partner, consider mapping the client to 
suffices on the server suffices tab, otherwise clients may also be specified for each 
partner. 

If you have SEAPI version 1 or 2 responder clients, the following fixed client 
names must be specified (according to the function mask(s) used by the client in 
SEAOpen): 

• SEAUNS – for unsolicited data access 

• SEAPER – for periodic data access 

• SEAREQ – for requested data access 
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• SEACMD – for command access 

These clients must also be mapped correctly to suffices at either server or partner 
level, the following screen dump shows a correctly configured suffix list for all 
these: 

 

Figure 3 Sample Version 1/2 responder Suffix Configuration 

4.3 Partner Configuration 
Create partners with the New Partner command, from the file menu or context 
menu, then supply the following data: 

In the main tab: 

• If you want to have different object names for the partner and the client(s), 
use a different object directory names, otherwise use the object directory 
name you specified for the client(s). 

• Ensure partner names are unique. 

• Select the proper Elcom version (the default is usually appropriate). 

• Select whether the partner may autoconfigure object names. In this mode 
you must have the same names for partner and client, and there is no 
access control for object configuration. On the other hand, you do not have 
to configure any object names. 
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• Add the partners certificate name (X.509 canonical name) if using TLS as 
the transport. Note: Use of this field requires the Elcom provider system to 
be properly configured for TLS, see [4]. 

In the addresses tab, add at least one address for the partner. This must match the 
address the remote partner uses to identify itself in the Elcom connect requests. 

4.4 Object X-ref Configuration 
If one or more partners have the autoconfigure option deselected, object sets must 
be created to define the allowable object names, possibly with a cross-reference to 
client names. Select the command New Object Set from the File menu or the 
context menu. 

On the Directories tab, one or two object directory names must be provided. If 
you want access control, but no cross-reference, supply only one, otherwise 
supply two, for cross-reference and access control. The object directory names 
must match the settings for object directory on the partner(s) and client(s) that 
should use these objects. 

You may now add objects in lists by selecting the tab according to type and 
command access or not. In an empty list, right-click in the gray area and select 
Insert Row to get started. Once in the list, using tab or the down arrow on the last 
row will insert a new, empty row. Use the delete row command on the right-click 
to delete empty rows prior to saving or moving to another tab. 

4.5 Verifying Configuration 
Save the file, either directly to sears-cfg.ecf in the runtime directory, or to any 
other name to work more later (again: do not save to a running system with this 
name). 

Start or restart the Elcbas Responder system, and use the log files or other means 
to verify operation.  

As mentioned above, if the configuration was read from the responder, save will 
write it back to it, and invoke a restart function. 

Once the responder is running, the configuration may be re-read to inspect any 
groups created by remote partners. 
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5. Reference Information 

5.1 Menus 

5.1.1 The File Menu 
The File menu contains the following 

• The New submenu: 

o New Configuration – Create a blank configuration file. Select 
configuration type (Initiator or Responder) from the popup. 
Always available. 

o New Partner – Create a new partner. Available if the selected item is 
a file/configuration. 

o New Client – Create a new client. Available if the selected item is a 
file/configuration. 

o New Group – Create a new Group. Available if the selected item is a 
partner in an Initiator configuration. 

o New Object Set – Create a new object set. Available if the selected 
item is a Responder configuration/file. 

• Open… – Open a configuration from a file. 

• Close – Close the current configuration and view (will prompt if 
modified). 

• Save – Save the current configuration. If configuration was read from a 
server (Initiator or Responder), send configuration restart request to the 
server. 

• Save As… – Save the current configuration to a new file name. NOTE: 
Currently this does not work with an online configuration. 

• The Get Active Configuration submenu: 

o Initiator – Get the current configuration from the initiator on the 
current computer. 

o Responder – Get the current configuration from the responder on the 
current computer. 

• Exit – Exit the program. Prompt to save any changes. 

In addition, the file menu has a list of the most recently opened configuration 
files. 
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5.1.2 The Edit Menu 
The edit menu contains a number of standard commands that are currently grayed 
out. These are left in place for future use. The following active commands are 
available: 

• Delete – Remove the selected item from the configuration, possibly with 
consistency checks and prompts. 

• Properties – Invoke the property editor for the selected item. 

5.1.3 The View Menu 
The View menu enables selected components of the user interface to be turned on 
or off: 

• Toolbar 

• Status Bar 

• Configuration Tree 

• Log Window 

5.1.4 The Tools Menu 
The Tools menu contains the following command: 

• Fetch Data – start a wizard to perform a manually requested data transfer. 
Available for groups in Initiator configurations if the configuration was 
read from the Initiator. 

5.1.5 The Window Menu 
The Window menu is a standard windows MDI window menu, which allows the 
views to be arranged within the View Area. 

5.1.6 The Help Menu 
The Help menu currently only has the About command. 

5.1.7 The Context Menu 
The context menu in the configuration tree has the following commands: 

• New Partner 

• New Client 

• New Object Set 

• New Group 

• Fetch Data 

• Delete 
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• Properties 

These correspond to the same commands in the main menu system. 

5.1.8 The Grid Context Menu 
The Grid context menu is available when editing the object lists in the group 
editor or the object set editor. It has the following commands: 

• Insert Row – insert a new row after the current row. 

• Delete Row – delete the current row. 

5.2 Dialogs 
This section documents all the dialogs in the program, with the exception of 
simple error messages and yes/no dialogs. 

5.2.1 The Server Properties Dialog 
The Server Properties dialog is accessed by selecting the file name (or server 
name, for online configuration) in the tree, and invoking the properties command 
from the edit menu/popup menu. 

This dialog is used to view and modify global parameters for either the initiator or 
responder part of Elcbas. 

5.2.1.1 The Identity Page 

 

Figure 4 Server Properties: Identity 
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This page contains the api name used with SEAPI and the elcom entity ID used 
with Elcom alib for the server. These values should normally not be modified. 

5.2.1.2 The Addresses Page 

 

Figure 5 Server Properties: Addresses 
This page is only available for the Initiator. It contains the Initiators own 
addresses which will be used in connect requests. 

To add a new address, press Add…, to modify or delete an address, click in the 
list to select an address, and press Edit… or Remove. Also, with an address 
selected, the arrow buttons can be used to change the order of addresses in the list. 

For add and edit, the following dialog is used: 
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Figure 6 Address Details 
The group field is a single character which may be used to create different sets of 
matching addresses, so that a certain initiator address is used for a certain partner 
address. This may be needed to communicate through firewalls that do address 
translation. 

Note also, that if TLS is used as the transport protocol, the address type is still 
specified as TCP in this dialog. The use of TLS is triggered by specifying a value 
in the Certificate name field for the relevant partners. 

5.2.1.3 The Timers Page 

 

Figure 7 Server Properties: Timers 
This page is only available for the responder. It sets the timers (in seconds) for the 
following functions: 

• Periodic Data Transfer – do not set this to more than 50 seconds. 

• Mixed Data (Medium Priority) Timer – used for priority class > 1 and <> 
0. 

• Mixed Data (Low Priority) Timer – used for priority class = 0 
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5.2.1.4 The Suffices Page 

 

Figure 8 Server Properties: Suffices 
This page shows the server’s own suffices, with additional information. The 
Listeners column is only used for the responder. Double click or select and press 
Modify… to change information for a suffix. You will then get this dialog: 

 

Figure 9 Server Properties: Suffix Details 
Here you may change: 

• The suffix string (usually not done).  

• (Responder Only) The number of listeners for this suffix (set to 0 to 
disable the function). 

• The client to use for this suffix (unless specified for partner). 
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5.2.1.5 The Logging Page 

 

Figure 10 Server Properties: Logging 
Here you may enable/disable the detailed Elcom API log. 

5.2.2 The Client Properties Dialog 
The Client Properties page is accessed either after the New Client command is 
invoked, or by invoking the Properties command for an existing client. It currently 
consists of a single property page. 

5.2.2.1 The Attributes Page 

 

Figure 11 Client Properties 
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Here you supply the attributes for a client: 

• The name, used for display and logs. 

• The API name, which must match the name used in SEAOpen in the client 
code. 

• The object directory, which defines which set of object names is used for 
this client. 

5.2.3 The Partner Properties Dialog 
The Partner Properties page is accessed either after the New Partner command is 
invoked, or by invoking the Properties command for an existing partner. It 
consists of the following pages, with some content different for initiator and 
responder partners. 

5.2.3.1 The Main Page 

 

Figure 12 Partner Properties: Main (Initiator) 
For initiator partners, the main page contains the following fields: 

• The name of the partner, used for display and logging. Note: The name 
should be unique. 

• The Elcom version/class to be used for this partner. 

• The Object Directory to be used for object names towards this partner. 
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• The Certificate name for this partner if TLS is used for this connection (the 
certificate name is the ‘Canonical Name’ field of an X.509 certificate). 

 

Figure 13 Partner Properties: Main (Responder) 
For responder partners, an additional flag for automatic configuration of object 
names is available. Setting this means that any object name supplied by a partner 
will be allowed at group configuration, thus simplifying configuration in some 
scenarios. It also has the following implications: 

• There is no access control on objects, at least not within Elcbas. 

• There is no cross-referencing between the partner names and client names, 
thus any clients serving such a partner must be configured with the same 
Object Directory name. 
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5.2.3.2 The Addresses Page 

 

Figure 14 Partner Properties: Addresses 
The addresses page allows up to four addresses to be specified for a partner.  

For the responder, the address is used to identify the partner at connect, thus 
addresses must be unique (please note that the gui currently does not check this). 

For the initiator, the addresses supplied are used in turn when attempting to 
connect to a remote system, thus providing support for redundant remote partners. 

To add a new address, press Add…, to modify or delete an address, click in the 
list to select an address, and press Edit… or Remove. Also, with an address 
selected, the arrow buttons can be used to change the order of addresses in the list. 

Add or edit brings up the address detains window, shown in Figure 6 Address 
Details. 
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5.2.3.3 The Suffices Page 

 

Figure 15 Partner Properties: Suffices 
The suffices page for a partner is used to specify configuration at the suffix level 
for a partner. To modify this information, either double-click on the function text, 
or select a line and press the Modify button. You will get the suffix details 
window: 

 

Figure 16 Suffix Details (Partner) 
The following fields can be set: 

• The Suffix code itself (usually not done; only for initiator partners). 

• The client that will handle requests/data for this suffix. If unspecified, the 
client specified at server level will be used. 
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• The object to use for signaling connection transitions. This is mainly 
useful for permanent connections. An object with the name specified will 
be sent as an indication to the client specified for the Test Connection 
suffix. 

• The Permanent Connection flag (initiator only) means that the initiator 
will attempt to maintain this connection, providing the associated client 
program is active. This may be used for any connection, and must be used 
for periodic and unsolicited data transfer connections. 

5.2.3.4 The Advanced Page 

 

Figure 17 Partner Properties: Advanced 
The advanced page in the partner editor shows the PID currently allocated to this 
partner (may be useful for reading some logs), and gives the option to clear the 
control field for the partner, thus forcing a reconfiguration at next restart. 

It also allows special confguration options to be set as named properties, using the 
Add/Modify/delete buttons. Such options should be documented in the release 
notes. 

5.2.4 The Group Properties Dialog 
The Group Properties page is accessed either after the New Group command is 
invoked, or by invoking the Properties command for an existing group. For the 
responder, this is a read-only dialog (save is disabled). 
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5.2.4.1 The Attributes Page 

 

Figure 18 Group Properties: Attributes 
The attributes page contains the following fields: 

• The Group ID should be selected so that it is unique for each partner. It 
must be a positive partner, and the remote partner may impose limits on 
the range. 

• The type is one of: 

o Float – single precision floating point 

o Integer – 16 bit signed integer 

o Status – two bit status value (on, off, between) 

• The transfer is one of: 

o Local – group will not be configured 

o None – group will be configured, but no transfer started 

o Unsolicited – group will be started for unsolicited data transfer 

o Periodic – group will be started for periodic data transfer 

o Command – group will be configured for command/setpoint 
(according to type) data transfer. 
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• Note that when viewing responder groups, transfer will show up 
(somewhat misleading) as ‘Local’, unless this is a command/setpoint 
group, in which case transfer will be shown as Command. 

• The priority field is the configured priority class (see Elcom 
documentation for usage). 

• The client field shows the client that will be used, assuming transfer is set 
to something other than Local or None. Currently this is read-only, as the 
group here is depending on configuration done for the partner and server. 
A future release will allow this to be set explicitly for each group (in the 
initiator). 

• The status field is only valid for the initiator. It shows ‘Unknown’ if the 
group was never configured, OK if the group was configured successfully, 
and Error if there was a configuration error. 

5.2.4.2 The Members Page 

 

Figure 19 Group Properties: Members 
The members page allow display and modification (in the initiator) of the objects 
comprising a group. It consist of an editable grid with one or two columns 
depending on whether cross-referencing is used. 

Move around in the grid using arrow keys and/or tab. Note that a blank row will 
terminate the group. 

You can paste in a column of names e.g. from excel. 
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Note that the responder configuration shows only the Elcom names, even if cross-
referencing is used, as the local names depends on the client, which is 
indeterminate when inspecting the configuration. 

5.2.4.3 The Cycles Page 

 

Figure 20 Group Properties: Cycles 
The cycles page (initiator only) allows up to six timed transfer schedules to be 
specified for a group (using the requested transfer mode). When adding or 
modifying a cycle, the cycle editor is shown. The details of this are described later 
in this chapter. 

Delete a cycle by selecting it and pressing the delete button. 

5.2.5 The Object Set Properties Dialog 
The Object Set Properties dialog is accessed by invoking the New Object Set 
command, or by selecting an existing Object Set and invoking the Properties 
command. The Object Set provides access control and optional cross-referencing 
between one or more partners and one or more clients. Object Sets are only used 
in responder configuration. 
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5.2.5.1 The Directories Page 

 

Figure 21 Object Set  Properties: Directories Page 
The directories page is used to specify the Object Directories comprising this 
Object Set. The first one must always be specified, and cannot be changed. The 
second one may, in principle, be changed, but this is not recommended once 
objects have been added to the Object Set. 
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5.2.5.2 The Object Pages 

 

Figure 22 Object Set Properties: Object Pages 
The object set dialog contains is split into a number of pages, grouping objects of 
the same type. Each page contains one or two columns according to the number of 
object directories used. 

The first line in each page is inserted using the popup menu on the right mouse-
button, and selecting insert row. Extra rows are inserted when tabbing or using the 
down arrow. Note that surplus blank rows must be deleted prior to saving. 

5.2.6 The Add/modify Cycle Dialog 
The Add/Modify Cycle dialog is accessed from the cycles page in the Group 
Properties dialog. 
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5.2.6.1 The Requested Values Page 

 

Figure 23 Cycle Dialog: Request Values Page 
This page specifies the time and amount of data that will be requested, and the 
source: 

• Select ‘Retrieve Latest Data Only’ to retrieve one set of data, with T0 set 
to –1, indication that the latest data available is requested. 

• Otherwise, select the number of data incarnations to request, the interval 
between incarnations, and the time for the first incarnation (T0). 

• You can also select whether to request data from the archived data suffix 
or the plan data suffix at the remote system. 

5.2.6.2 The Objects Page 
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Figure 24 Cycle Properties: Objects Page 
This page allows you to specify whether to request the entire group, or a 
contiguous subset, using index numbers (tip: indices are displayed in the main 
view when a group is selected in the tree). 

5.2.6.3 The Execution Page 

 

Figure 25 Cycle Properties: Execution Page 
The execution page allows you to enable/disable a cycle, as well as specifying 
when it should be run, and the interval between invocations. 

5.2.7 The Fetch Data Wizard 
The fetch data wizard is used to run a requested data transfer manually. It is 
available only when the initiator configuration is accessed from the server (i.e. 
loaded using the ‘Get Active Configuration’ menu). Basically, it consists of the 
first two pages from the Cycle Properties dialog, presented in a wizard form: 
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Figure 26 Fetch Data Wizard: Requested Values 
Pressing next gives: 

 

Figure 27 Fetch Data Wizard: Objects 
Pressing Finish will send a request to the initiator, waiting up to five minutes for 
its completion. The resulting data is sent to the client configured for the selected 
suffix for this partner. (A future version will provide display of data and explicit 
specification of client). 
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