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Requirements

e Install ParaView 4.4
e http://www.paraview.org = Download

* Get example material
e http://www.paraview.org/Wiki/The ParaView Tutorial
e Additional data on the thumb drives

 On the thumb drives:
e ParaView installers
e Tutorial data
e These slides, VTK Documentation (useful for python)



Introduction



What is ParaView?

 An open-source, scalable, multi-platform
visualization application.

e Support for distributed computation models to
process large data sets.

 An open, flexible, and intuitive user interface.

e An extensible, modular architecture based on open
standards.

e Large user community, both public and private
sector.

e A flexible BSD 3 Clause license.
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ParaView Application Architecture

Ul (Qt Widgets, Python Wrappings)

ParaView Server

VTK




ParaView Development

e Started in 2000 as collaborative effort between Los
Alamos National Laboratories and Kitware Inc. (lead by
James Ahrens)

e ParaView 0.6 released October 2002

e September 2005: collaborative effort between Sandia
National Laboratories, Kitware Inc. and CSimSoft to
rewrite user interface to be more user friendly and
develop quantitative analysis framework

e ParaView 3.0 released in May 2007
e ParaView 4.0 released in June 2013
e ParaView 5.0 recently released



More Information

- B ParaView Guide NN
i O n I I n e H e I p - F 1 i :::f:e.: Visualizafion Application 1 vrsen

e The ParaView User’s Guide
e http://www.paraview.org/paraview-guide/

 The ParaView web page
i WWW.paraview.org

., Ifkarsh fiyachit
VeKitware e

Hllparaview

e ParaView mailing list
e paraview@paraview.org




Basic Usage



ParaView Visualization Pipeline
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ParaView Visualization Pipeline
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User Interface
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Getting Back GUI Components

VAV Sources  Filters Tools Catalyst Macros Help

+ Active Variable Controls &

! Animation View v Camera Controls
Collaboration Panel v Center Axes Controls

Color Map Editor v Common. |
v Current Time Controls |_

v DataAnalysis

v Macros Toolbars

v Main Controls i
v Representation Toolbar =
v VCR Controls

. Comparative View Inspector
v Information
] Memory Inspector
Multi-block Inspector
v Pipeline Browser
v Properties
Selection Display Inspector
Statistics Inspector

Toggle Borders ¥D
Full Screen F11




Pipeline and Information Panels

Pipeline Browser

x Information

T
B builtin:

|
- ©

Statistics

Type: Paolygonal Mesh
Mumber of Cells: 18
Mumber of Points: 64
Memory: 0.005 MB

Data Arrays

Name Data Type

@ Mormals float
¢ TCoords float

Data Ranges

(-1, 1], [-1, 1], [-1, 1]
[-0.5, 1], [-0.5, 1]

Bounds

¥ range: -0.5to 0.5 (delta: 1)
¥ range: -0.5 to 0.5 (delta: 1)
Zrange: -0.5to 0.5 (delta: 1)

Time

Index Value




Data Types

Uniform Rectilinear
(vtkimageData)

Polygonal
(vtkPolyData)

Non-Uniform Rectilinear
(vtkRectilinearData)

Unstructured Grid
(vtkUnstructuredGrid)

Curvilinear
(vtkStructuredData)

Multi-block

Hierarchical Adaptive
Mesh Refinement
(AMR)

Hierarchical Uniform
AMR

Octree



Properties Panel (1)

Search

Settings \[ ' Apply ” @ Reset || % Delete ||
Search ... (use Esc to clear text)
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Properties Panel (2)
= Display (GeometryRepresentation) |@| @ )

Representation
\ [ ] cube Axes Visibility

Representation lgurface v] Edit Transfer
Coloring Function
Color mode ——'| < Temperature '|
l o Show J | ms Edit iI | .. Rescale v\‘\ .
Show legend /mhrmhring Adjust T.F.

Map Scalars Range

Interpolate Scalars Before Mapping

/ Styling =

Opacity ] 1

Foint Size 2

Line Width 1

Lighting
Representation < Interpolation [Gouraud v]
settings (many) Specular [ 0

IO Specular Color ]

Specular Power [ ] 100

Ambient [} 0

\ Diffuse ] 1



Properties Panel (3)

Axes W/ ticks = View (Render View) ||fﬂ| [Ty pi

in the scene Edit Aves Grid .. |
[ ] Center Axes Visibility Orientation

Orientation Axes / axes in 3D

Orientation Axes Visibility
|:| Orientation Axes Interactivity

] [O Orientation Axes Label Color ']
nght [O Orientation Axes Outline Color "]
settings Lights
Background
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[Single color T]

[‘ Color "] |Restcrre Default| —




Creating a Cylinder Source

1. Go tothe Source menu and select Cylinder

2. Click the Apply button to accept the default
parameters. | = Apply |

3. Increase the Resolution parameter

Resolukion J 6

4. Click the Apply button again | = Apply |
Click the Delete button to delete the cylinder

| 2L Delete |




Loading a data file

1. Go to the File menu and select Open
2. Locate and select the file disk_out ref.ex2

3. Inthe Properties panel, select the variable

arrays to load 7 Variables

V| ff Object Ids

4. Click [ 5 Apply ] 7] f Global Element Ids
2% Global Node Ids

22 Temp

2V

2% Pres

52 AsH3

22 GaMe3

3% CH4

2% H2

] O e O e O O ™




Supported File Types

* EnSight (.case, .so0s) * NASTRAN (.nas, .f06)

e VTK (.vtp, .vtu, .vti, vts, .vtr) * Enzo boundary and hierarchy * Nek5000 Files

* VTK Legacy (.vtk) e Exodusll (.g, .e, .exe, .ex2, .ex2v.., * Nrrd Raw Image (.nrrd, .nhdr)

* VTK Multi Block etc) * OpenFOAM Files (.foam)
(.vtm,.vtmb,.vtmg,.vthd,.vthb)  * ExtrudedVol (.exvol) e PATRAN (.neu)

* Partitioned VTK (.pvtu, .pvti, * FVCOM (MTMD, MTSD, Particle, ¢ PFLOTRAN (.h5)
.pvts, .pvtr) STSD) * PLOT2D (.p2d)

e ADAPT (.nc, .cdf, .elev, .ncd) * Facet Polygonal Data * PLOT3D (.xyz, .q, .X, .vp3d)

e ANALYZE (.img, .hdr) * Flash multiblock files * PLY Polygonal File Format

e ANSYS (.inp) * Fluent Case Files (.cas) * PNG Image Files

e AVS UCD (.inp) * GGCM (.3df, .mer) * POP Ocean Files

* BOV (.bov) e GTC (.h5) * ParaDIS Files

* BYU (.g) * GULP (.trg) * Phasta Files (.pht)

e CAM NetCDF (.nc, .ncdf) * Gadget (.gadget) * Pixie Files (.h5)

* CCSM MTSD (.nc, .cdf, .elev, .ncd) * Gaussian Cube File (.cube) * ProSTAR (.cel, .vrt)

e CCSM STSD (.nc, .cdf, .elev, .ncd) ¢ JPEG Image (.jpg, .jpeg) * Protein Data Bank (.pdb, .ent,

e CEAucd (.ucd, .inp) ¢ LAMPPS Dump (.dump) .pdb)

e CMAT (.cmat) e LAMPPS Structure Files * Raw Image Files

e CML (.cml) * LODI (.nc, .cdf, .elev, .ncd) * Raw NRRD image files (.nrrd)

e CTRL (.ctrl) * LODI Particle (.nc, .cdf, .elev, .ncd)* SAMRAI (.samrai)

e Chombo (.hdf5, .h5) ¢ LS-DYNA (.k, .Isdyna, .d3plot, * SAR (.SAR, .sar)

* ParaView Data (.pvd)

* Claw (.claw) d3plot) * SAS (.sasgeom, .sas, .sasdata)

e Comma Separated Values (.csv) ¢ M3DCI (.h5) * SESAME Tables

* Cosmology Files (.cosmo, * MFIX Unstructred Grid (.RES) * SLAC netCDF mesh and mode
.gadget2) * MMS5 (.mm5) data

* MPAS NetCDF (.nc, .ncdf)
* Meta Image (.mhd, .mha) * Silo (.silo, .pdb)

* Miranda (.mir, .raw) * Spheral (.spheral, .sv)
* Multilevel 3d Plasma (.m3d, .h5) ¢ SpyPlot CTH

* Curve2D (.curve, .ultra, .ult, .u) * SLAC netCDF particle data
e DDCMD (.ddcmd)
* Digital Elevation Map (.dem)

* Dyna3D(.dyn)

* SpyPlot (.case)

* SpyPlot History (.hscth)
* Stereo Lithography (.stl)
* TFT Files

* TIFF Image Files

* TSurf Files

* Tecplot ASCII (.tec, .tp)
* Tecplot Binary (.plt)

e Tetrad (.hdf5, .h5)

* UNIC (.h5)

* VASP CHGCA (.CHG)

« VASP OUT (.OUT)

* VASP POSTCAR (.POS)

* VPIC (.vpc)

* VRML (.wrl)

* Velodyne (.vld, .rst)

* VizSchema (.h5, .vsh5)
* Wavefront Polygonal Data (.obj)
* WindBlade (.wind)

* XDMF and hdf5 (.xmf, .xdmf)
* XMol Molecule



Geometry Representations

Properties panel VS Representation toolbar
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Coloring
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Simple Camera Manipulation

e Drag left, middle, right buttons for rotate, pan, zoom
e Additional options with Shift, Ctrl, Alt modifiers
* |f no middle button, use Shift + right button

o %! . +X =X +Y =Y 2% -2 b i | =]
Jx:-. % ' f:ﬁ ﬁ} I‘i\'J=h -I=1ﬂl 4=1‘|J L:& = Wog '*'::E:-’-r_;';' (g

e Save screenshots
e File -> Save screenshot ... (export as an image)
e File -> Export scene ... (depends on the view)



Keep in mind

* You can save/load your settings
and pipeline

* You can undo/redo operations

[Eile] Edit View Sources Filters Tc

o
=

Open..

Recent Files LA |

Ctrl+O f

Load State...
Save State...

Sources Filters Toc

a2

6 Sl oo Temp

* You can undo/redo camera movements

O Layout #1 % -F




Data Filtering



Common Filters

Calculator @ Glyph

"\- Stream Tracer

[9 Warp (vector)




Filters Menu

T::u::-ls Macros Help

| Search... _Space ¥
Recent »
AMR
CTH
Common
| CosmoTools

Data Analysis
| Material Analysis
Quadrature Points
Statistics

Temporal
Alphabetical I
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Filters Menu

Eilters] Tools Catalyst Macros Hi

Search... Ctrl+Space
Recent 4
AMR 4
Annotation 4
CTH b
Common 4
Data Analysis 4
Material Analysis 4
Quadrature Points 4
Statistics 4
Temporal 4
Alphabetical 4

ED

AMR Connectivity

AMR Contour

AMR CutPlane

AMR Dual Clip

AMR Fragment Integration
AMR Fragments Filter
Add Field Arrays
Angular Periodic Filter
Annotate Attribute Data
Annotate Global Data
Annotate Time Filter
Append Attributes
Append Datasets
Append Geometry
Block Scalars

Calculator

Cell Centers

Cell Data to Point Data
Clean

Clean Cells to Grid
Clean to Grid

Clip

Clip Closed Surface

Clip Generic Dataset
Compute Derivatives
Compute Quartiles
Connectivity
Contingency Statistics
Contour

Contour Generic Dataset
Convert AMR dataset to Multi-block
Curvature

D3

Decimate

Delaunay 2D

Delaunay 3D
Descriptive Statistics
Elevation

Environment Annotation
Extract AMR Blocks
Extract Bag Plots
Extract Block

Extract CTH Parts
Extract Cells By Region

Extract Component

Extract Edges

Extract Generic Dataset Surface
Extract Level

Extract Location

Extract Region Surface

Extract Selection

Extract Subset

Extract Surface

FFT Of Selection Over Time
Feature Edges

Gaussian Resampling

Generate Ids

Generate Quadrature Points
Generate Quadrature Scheme Dictionary
Generate Surface Normals
Glyph

Glyph With Custom Source
Gradient

Gradient Of Unstructured DataSet
Grid Connectivity

Group Datasets

Histogram

Image Data To AMR

Image Data to Point Set
ImageResampling

Integrate Variables

Interpolate to Quadrature Points
Intersect Fragments

Iso Volume

K Means

Legacy Glyph

Level Scalars{Non-Overlapping AMR}
Level Scalars{Overlapping AMR)
Linear Extrusion

Loop Subdivision

Mask Points

Material Interface Filter

Median

Merge Blocks

Mesh Quality

Multicorrelative Statistics
Normal Glyphs

Octree Depth Limit

ce

&

{3

®

Octree Depth Scalars
Outline

Outline Corners

Outline Curvilinear DataSet
ParticlePath

ParticleTracer

Pass Arrays

Plot Data

Plot Global Variables Over Time
Plot On Intersection Curves
Plot On Sorted Lines

Plot Over Line

Plot Selection Over Time
Point Data to Cell Data
Principal Component Analysis
Probe Location

Process Id Scalars
Programmable Filter
Python Annotation

Python Calculator

Quadric Clustering

Random Attributes
Random Vectors

Rectilinear Data to Point Set
Rectilinear Grid Connectivity
Reflect

Resample AMR

Resample With Dataset
Ribbon

Rotational Extrusion

Scatter Plot

Shrink

Slice

Slice (demand-driven-compasite)

Slice AMR data

Slice Along PolyLine
Slice Generic Dataset
Smaooth

StreakLine

Stream Tracer

Stream Tracer For Generic Datasets
Stream Tracer With Custom Source

Subdivide
Surface Flow

Surface Vectors

Table To Points

Table To Structured Grid
Temporal Cache
Temporal Interpolator
Temporal Particles To Pathlines
Temporal Shift Scale
Temporal Snap-to-Time-Step
Temporal Statistics
Tensor Glyph

Tessellate

Tetrahedralize

Texture Map to Cylinder
Texture Map to Plane
Texture Map to Sphere
Threshold

Transform

Transpose Table

Triangle Strips
Triangulate

Tube

Warp By Scalar

Warp By Vector

Youngs Material Interface




Quick Launch

( surf extract )

"T Extract Surface

Extract Surface

Type to search. Enter to select.

Esc to cancel.

e Used for searching for
filters by name

e Keyboard shortcut
e Ctrl-space
(Windows & Linux)
e Alt-space
(Apple)



Apply a Filter

1. Make sure that disk_out_ref.ex2 is selected in
the pipeline browser.

2. Select the contour filter. @



Apply a Filter

3. Change parameters to create an isosurface at
Temp = 400K.

a8aco Properties

I Apply Reset )( % Delete ) 7 )

Search...

= Properties (Contourl) M

Contour

Change to Temp ——eonwarsy— o Ashia 5

¥ Compute Normals
Compute Gradients
Compute Scalars

Isosurfaces

Value Range: [0.0804768, 0.184839]

Change to 400 — > 0.132658146 Delete

[ Delete Al )

[ MNewvalue

[ New Range )|

[ Scientific



Apply a Filter

1. Make sure that disk_out_ref.ex2 is selected in
the pipeline browser.

Select the contour filter. @

3. Change parameters to create an isosurface at
Temp = 400K.

4. | & apply |




Create a Cutaway Surface

1. Select disk_out_ref.ex2 in the pipeline
browser.

2. From the quick launch, select
Extract Surface.

3. | & Apoly |

4. Create a Clip filter. @

5. Uncheck Show Plane. V] Shaw Flane
6. [ = Apply ]




Pipeline Browser Structure

Fipeline Browser

|
E builtin:

@ -I disk_out_ref.ex2
@@ W Contourl
@ =87 ExtractSurfacel

@ ‘ Clipl

Disk_out_ 4
ref.ex2

DATA SOURCES

ExtractSur
facel

PolyData

Mapper

T

FILTERING

Mapper

OUTPUT

PolyData

Rendering ...
L e e e e e e -




Reset ParaView

Edit > Reset Session

File View Sources Filt
Can't Undo £Z B
Can't Redo R

L

&£

Camera Undo 38B
Camera Redo  2F

Find Data... W
Change Input... E
Copy
Paste

E = |_ﬁ-."'|I

gnore Time
Delete
Reset Session




Multiview

Ml ParaView 4.4.0 64-bit

m/g/a]&][x]

VA

Eile Edit View Sources Eilters Tools Catalyst
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Macros Help
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Information

Data Hierarchy
4 Multi-block Dataset
> Element Blocks
Face Blocks
Edge Blocks
Element Sets
> Side Sets
Face Sets
Edge Sets
> Node Sets

Properties
Filename: disk_out_ref.ex2
Path: C:/Users/andrea/Desktop/ParaViewTutorialData
Statistics

Type: Multi-block Dataset

Number of Cells: 7472

Number of Points: 8499

Memory: 2 MB

Data Arrays
Current data time: 0

| »

m

Temp
9.132e+02

Pripertie: &8 X

Apply Reset

2.931e+02

Search ... (use Esc to clear text)
= properties (disk_out_ref.ex Eb |« |

Variables

£ Object Ids

f# Global Element Ids
Global Node Ids

1

Apply Displacements

Displacement
Magnitude

Edge Blocks

1

[Clsets

[ %% Unnamed set ID: 1
[71%% Unnamed set ID: 2
[ %2 Unnamed set ID: 3
[C] % Unnamed setID: 1
"] & Unnamed set ID: 2
[C] % Unnamed setID: 3
[C] & Unnamed setID: 4
[C] /# Unnamed setID: 5
"] Unnamed setID: 6
[C] /# Unnamed setID: 7

‘ Properties | Color Map Editor




Multiview

Open disk_out_ref.ex2 (all variables)

Add a Clip Filter @

[ F Apply ]
Uncheck Show Plane. [¥] show Flane
Color surface by Pres.

| = Apply |

o U kA wh =




Multiview

RenderViewl| [D|[E]O](F][x]
. |

Split the view horizontally
Make Clip1 visible

Color surface by Temp
Right-click view, Link Camera...

10. Click other view

11. Modify a view, changes are applied to both

© o N O

12. Swap views dragging them with the mouse



Reset ParaView

Edit > Reset Session

File View Sources Filt
Can't Undo £Z B
Can't Redo R

L

&£

Camera Undo 38B
Camera Redo  2F

Find Data... W
Change Input... E
Copy
Paste

E = |_ﬁ-."'|I

gnore Time
Delete
Reset Session




Streamlines

Open disk_out_ref.ex2 (all variables)

Add Stream Tracer G)=

=

[ F= Apply ]

From the quick launch, select Tube

A

[ F= Apply ]




Improve Streamlines

Select StreamTracerl

Add a Glyph filter

Change Vectors to V

Change Glyph Type to Cone
10. [ = Apply ]

© 0 N o




Getting Answers

e Where is the air moving the fastest? Near the disk
or away from it? At the center of the disk or near
its edges?

 Which way is the plate spinning?

e At the surface of the disk, is air moving toward the
center or away from it?



Reset ParaView

Edit > Reset Session

File View Sources Filt
Can't Undo £Z B
Can't Redo R

L

&£

Camera Undo 38B
Camera Redo  2F

Find Data... W
Change Input... E
Copy
Paste

E = |_ﬁ-."'|I

gnore Time
Delete
Reset Session




Vo
SL

Al S

ume Rendering +
rface Geometry

Open disk_out_ref.ex2 (all variables)
Add an Extract Surface and a Clip filter
Select disk_out_ ref.ex2

Change variable viewed to Temp

Change representation to Volume

!



Transfer Function Editor

4>

[ i

Opacity Editor

Color Editor

v

v

Show Legend

Color Map Editor

) () (!
e, Edit Legend

Search ... (use Esc to clear text)

Array Name: Temp

|| Lock Data Range

[ mnterpret values As Categories
|| Rescale On Visibility Change
Mapping Data

Edit
data range

Ce—
Invert

Load / Save

&R

> v
Data:
|:| Use log scale when mapping data to colors

|| Enable opacity mapping for surfaces
Color Mapping Parameters

Color Space

[O MNan Color

Color Discretization

Discretize

MNumber Of Table |
Values D 256

P [l
e -

lDiverging A

Render Views



Transfer Function Editor

e Opacity Editor
e Left click: add/move control point
e Left double click: edit slope
e Right click: select (can move together)
 Mouse wheel: zoom

e Color Editor
e Left click: add/move control point
e Left double click: edit color
* Mouse wheel: zoom



Modify Transfer Function

Select disk_out_ref.ex2

Click Edit Color Map

Click Choose preset

Select Black-Body Radiation

Try adding and changing control points

A S

If you see nothing, try changing the Volume
Rendering Mode parameter!



Histograms

Select disk out ref.ex?2

Add a Histogram filter ‘ |
Change variable to Temp
Set Bin count to 32

B W

The histogram can useful for setting up the Transfer
Function for volume rendering



Reset ParaView

Edit > Reset Session

File View Sources Filt
Can't Undo £Z B
Can't Redo R

L

&£

Camera Undo 38B
Camera Redo  2F

Find Data... W
Change Input... E
Copy
Paste

E = |_ﬁ-."'|I

gnore Time
Delete
Reset Session




Common Data Analysis Filters

_IJ Extract Selection

% Plot Global Variables Over Time

O Plot Selection Over Time

WA
>'< Probe Location



Plotting

Add a Clip Filter
Uncheck Show Plane ¥] Show Plane

Select disk out ref.ex?2 R
Add Plot Over Line filter. @@‘

Open disk_out_ref.ex2 (all variables) @

Al S



3D Widgets

fanon M ParaView 3.14.1-1643-g2537cab 64-bit
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E builtin:
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@ B0 disk_out_ref.ex2

@ B Clipl

[+ PlotOverLinel

E‘ﬁ'ﬁpﬁl‘ﬁﬁ!—! Information |

0 @ Properties
[Ef Apply ) Reset (3 Delete )( ?
Search...

= Properties (PlotOverLinel)

Probe Type | High Resolution Line Source I%i

E Show Line

Pointl -5.75 -5.75 -10

Point2 5.75 5.75 10.159999;
( X Axis )
( Y Axis )
( Z Axis )
Resolution 100 @

Note: Mave mouse and use 'P' kev to
= A




Interacting with Plots

e Left, middle, right buttons to pan and zoom.
e Mouse wheel to zoom

e Reset view to plot ranges x

e Plots are views, they can be dragged around



Adjusting Plots

e Different attributes can have different orders of
magnitude

1. In Display section of properties panel, turn off
all variables except Temp and Pres

* Pres will be too small to be visualized
2. Select Pres in the Display options
3. Change Chart Axis to Bottom - Right.



Reset ParaView

Edit > Reset Session

File View Sources Filt
Can't Undo £Z B
Can't Redo R

L

&£

Camera Undo 38B
Camera Redo  2F

Find Data... W
Change Input... E
Copy
Paste

E = |_ﬁ-."'|I

gnore Time
Delete
Reset Session




Exercises

e Exercise 1
 Load Bergen terrain dataset
e Remove invalid data (Height = -9999)
e Make it 3D using the Height data
e Set a suitable color map
e Display height curves every 100m
 Displayin red the steepest regions

e Suggested filters: Calculator, Contour, Extract
Subset, Gradient (or Gradient of Unstr. Grid),
Histogram (use custom bin range), Threshold,
Warp by Scalar



Exercises

Height
-2.000e+02 18.5 237 455 6.739e+02
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Exercises

e Exercise 1 - Bonus

e Show a tree every 20 pixel on terrain between 200m
and 400m

 Show tangent curves of the gradient vector field, at a
suitable resolution

e Use various sources, Append Geometry, Extract Subset,
Glyph with Custom Source, Stream tracer with Custom
Source, Threshold, Warp by Scalar, ...



Exercises

Exercise 2

Load headsq.vti
Find data values associated with tissue types

In multiple views and multiple layouts, show
e Astack of slices
e A surface representing the skin, and one for the skull
A volume emphasizing high values of gradient magnitude
 Avolume showing what’s wrong with this guy
In a new layout
e Highlight what you have found

e Plot values across the interesting area
* Create a slice through the interesting area

Use Contour, Histogram, Probe, Polyline, Slice, etc.



Exercises .




Exercises




